Home page of Satellite Internet and Information

Satellite Internet Forum.

Welcome, Guest.
Welcome to this satellite broadband discussion forum. Wherever you are and whatever your problem we are here to help each other. Connecting to the internet via satellite is not always easy but is critically important to those in remote places or with poor terrestrial infrastructure. Both service providers and customers are encouraged to contribute. Register at the bottom of the forum home page if you wish to contribute or ask question. Read the Forum rules.
      Satellite Internet Forum : Home Page          
Pages: 1

iDirect 3100 Upgrade problem

(Read 2204 times)
Ex Member
Ex Member


Mar 22nd, 2009 at 8:19pm  
Hi,

I have Modem with Ver. 6.0.9.5 and i need to upgrade to Ver. 8.2.2.0.
I have the packages and i can establish connection both on WinSCP and Console cable.
After doing step by step following iDirect's Recovery procedure, i get the error below, after running command ./package_install.sh .... Kindly help.
************************************
zImage
Package Install: checking for required files
Package Install: kernel version 2.4.24-uc0-iDirect0
Package Install: installing files
datafile startup_bsp_manifest.xml already matches /etc/idirect/startup_bsp_manif
est.xml, skipping
datafile ext_manifest.xml already matches /etc/idirect/ext_manifest.xml, skippin
g
uncompressing libcrypto.so.0.9.7.bz2 -> libcrypto.so.0.9.7
./package_install.sh: 185: bunzip2: not found
rm: unable to remove `/tmp': Device or resource busy


exit: 185: Illegal number: failed
/tmp #


Back to top
 
 
IP Logged
 
Ex Member
Ex Member


Reply #1 - Mar 22nd, 2009 at 9:34pm  
Looks like the bsp (cumulative update) install was successful.  That 8.2 package you are installing, is it zipped?

How are you negotiating this upgrade:  TFTP thru iSite?  Or with WinSCP and command line?

If iSite what version are you using?
Back to top
 
 
IP Logged
 
Ex Member
Ex Member


Reply #2 - Mar 23rd, 2009 at 4:56am  
TDMAmike,

Thanks for your email.
I think the 8.2.2.0 package is not Zipped. It has a .pkg at the end and not .zip
I have tried through TFTP and Console command line only (tera-term and Hyperterminal). I am getting same results.
I am not able to use iSite - because iSite cannot find modem though i have IP connectivity and i can ping the modem.
I have tried isite versions 6.0, 7.0.1.4, 7.1.1 and 8.2.2.0

Regds, Martin
Back to top
 
 
IP Logged
 
Ex Member
Ex Member


Reply #3 - Mar 23rd, 2009 at 11:13am  
Prior to starting did you increase teh swap space of /tmp by typing the following:

df
mount -t tmpfs -o remount,size=16M /tmp
df


Can you provide the exact command line strings you are using (in conjuction with WinSCP).

Please walk me thru your entire upgrade process (via cmd line)....starting with dropping the upgrade packages (cumulative update and image) in the /tmp folder on the remote/iDU.

M
Back to top
 
 
IP Logged
 
Pages: 1