Satellite Internet forum
https://www.satsig.net/cgi-bin/yabb/YaBB.pl
VSAT technology and installation >> iDirect Forum: hubs and terminals >> x3 cpu usage
https://www.satsig.net/cgi-bin/yabb/YaBB.pl?num=1222782993

Message started by cylent on Sep 30th, 2008 at 2:56pm

Title: x3 cpu usage
Post by cylent on Sep 30th, 2008 at 2:56pm
my x3 cpu usage always rises.
i know from my ex-3100 it should always reside in the 1-10% zone.

when should i start to worry?

Title: Re: x3 cpu usage
Post by TDMAMike on Oct 1st, 2008 at 1:59am
You are one of few using the new iDirect S2 modem. I dont have anything to contribute as I lack experience with that modem, but I am certainly following along with your posts.

Title: Re: x3 cpu usage
Post by cylent on Oct 1st, 2008 at 8:36am
this is what its showing now with hardly any traffic going in or out.


Quote:
[RMT:6666] admin@telnet:::ffff:127.0.0.1;1024
> cpu
CPU Load : 7%

[RMT:6666] admin@telnet:::ffff:127.0.0.1;1024
> ps
†PID †Uid † † VmSize Stat Command
† †1 root † † † †508 S † init [2]
† †2 root † † † † † †SW †[keventd]
† †3 root † † † † † †SWN [ksoftirqd_CPU0]
† †4 root † † † † † †SW †[kswapd]
† †5 root † † † † † †SW †[bdflush]
† †6 root † † † † † †SW †[kupdated]
† †8 root † † † † † †SW †[mtdblockd]
† 42 root † † † † † †SWN [jffs2_gcd_mtd2]
† 61 root † † † † † †DW †[ixp425_csr]
† 63 root † † † † † †SW †[ixp425 ixp0]
† 65 root † † † † † †SW †[ixp425 ixp1]
†216 root † † † †564 S † /sbin/syslogd -m 0
†219 root † † † †544 S † /sbin/klogd
†240 root † † † 1408 S † /usr/sbin/sshd
†365 root † † †16832 S † /usr/sbin/falcon
†371 root † † †16832 S † /usr/sbin/falcon
†372 root † † †16832 S † /usr/sbin/falcon
†373 root † † † †936 S † /usr/sbin/falcon_monitor
†381 root † † † †308 S † /bin/ptylogin
†382 root † † † †720 S † -ash
†383 root † † † †304 S † /bin/ptylogin
†390 root † † † †632 S † telnet 0
†391 root † † † †648 R † /bin/ps

[RMT:6666] admin@telnet:::ffff:127.0.0.1;1024


start doing a bit of browsing and you'll see cpu report 30% usage almost immediately!

I think it has to do with the fact that i am using a 240 subnet because i had a similar incident with a 3100 in the past and we resolved it by assigning a public ip ...

on a side note if run the "top" command logged in as root through console i can see that falcon consumes 16M of memory and near almost all the cpu.

iDirect really should take part in optimizing the falcon code.


Quote:
Mem: 36340K used, 26304K free, 0K shrd, 0K buff, 12048K cached
Load average: 1.18, 1.06, 1.01 † †(State: S=sleeping R=running, W=waiting)

†PID USER † † STATUS † RSS †PPID %CPU %MEM COMMAND
†365 root † † R † † † †16M † † 1 †8.7 26.8 falcon
†392 root † † R † † † †712 † 382 †1.9 †1.1 busybox
†371 root † † S † † † †16M † 365 †0.0 26.8 falcon
†372 root † † S † † † †16M † 371 †0.0 26.8 falcon
†240 root † † S † † † 1408 † † 1 †0.0 †2.2 sshd
†373 root † † S † † † †936 † † 1 †0.0 †1.4 falcon_monitor
†382 root † † S † † † †720 † 381 †0.0 †1.1 ash
†216 root † † S † † † †564 † † 1 †0.0 †0.9 syslogd
†219 root † † S † † † †544 † † 1 †0.0 †0.8 klogd
† †1 root † † S † † † †508 † † 0 †0.0 †0.8 init
†381 root † † S † † † †308 † † 1 †0.0 †0.4 ptylogin
†383 root † † S † † † †304 † 381 †0.0 †0.4 ptylogin
† †6 root † † SW † † † † 0 † † 1 †0.0 †0.0 kupdated
† †2 root † † SW † † † † 0 † † 1 †0.0 †0.0 keventd
† †3 root † † SWN † † † †0 † † 1 †0.0 †0.0 ksoftirqd_CPU0
† †4 root † † SW † † † † 0 † † 1 †0.0 †0.0 kswapd
† †5 root † † SW † † † † 0 † † 1 †0.0 †0.0 bdflush
† †8 root † † SW † † † † 0 † † 1 †0.0 †0.0 mtdblockd
† 42 root † † SWN † † † †0 † † 1 †0.0 †0.0 jffs2_gcd_mtd2


i am also dying to find out why falcon is running in three instances. (365, 371, 372) each consuming 16M of memory (totaling 48M).
The whole modem only has 64 so they're nearly chocking it!!!
then you get a piece of junk xscale arm processory running at ONLY 266Mhz!
wow! talk about cheap!!!!!

I wonder if i can overclock this thing.... hmm...

Processor       : XScale-IXP4xx/IXC11xx rev 2 (v5b)
BogoMIPS        : 266.24
Features        : swp half thumb fastmult edsp

Hardware        : iDirect Phoenix Platform
Revision        : 0000
Serial          : 0000000000000000

Title: Re: x3 cpu usage
Post by Q on Oct 1st, 2008 at 10:14am
Currently i am going to configure a large batch. Therefore i shall post my findings. Have you kill the extra X 2 PID falcon. If so what happened ?

Have you loaded iperf ? Do you get the same type of mem usage ?  Is it http traffic only ?  

Title: Re: x3 cpu usage
Post by cylent on Oct 1st, 2008 at 11:00am
no i have not killed the extra 2.

i will kill them later today and will update my findings.

by the way this is 9.0.0.5

i have not used iperf yet. will also do that later.

Title: Re: x3 cpu usage
Post by cylent on Oct 1st, 2008 at 7:54pm
ok i killed the other two

now top only shows 1 running and the system seems to be ok.

Mem: 36532K used, 26112K free, 0K shrd, 0K buff, 12048K cached
Load average: 1.02, 1.02, 1.00    (State: S=sleeping R=running, W=waiting)

 PID USER     STATUS   RSS  PPID %CPU %MEM COMMAND
 365 root     R        16M     1 11.1 26.9 falcon
 401 root     R        760   382  0.5  1.2 busybox
 240 root     S       1408     1  0.0  2.2 sshd
 373 root     S        936     1  0.0  1.4 falcon_monitor
 382 root     S        824   381  0.0  1.3 ash
 216 root     S        564     1  0.0  0.9 syslogd
 219 root     S        544     1  0.0  0.8 klogd
   1 root     S        508     0  0.0  0.8 init
 381 root     S        308     1  0.0  0.4 ptylogin
 383 root     S        304   381  0.0  0.4 ptylogin
   6 root     SW         0     1  0.0  0.0 kupdated
   2 root     SW         0     1  0.0  0.0 keventd
   3 root     SWN        0     1  0.0  0.0 ksoftirqd_CPU0
   4 root     SW         0     1  0.0  0.0 kswapd
   5 root     SW         0     1  0.0  0.0 bdflush
   8 root     SW         0     1  0.0  0.0 mtdblockd
  42 root     SWN        0     1  0.0  0.0 jffs2_gcd_mtd2
  61 root     DW         0     1  0.0  0.0 ixp425_csr
  63 root     SW         0     1  0.0  0.0 ixp425 ixp0


i am not too familiar on using iperf. can you advise on how to set it up for this purpose?
thx

Title: Re: x3 cpu usage
Post by TDMAMike on Oct 2nd, 2008 at 3:44am
I have never used iperf either.  I prefer IXChariot.

Still interested in any feedback from anyone who knows how to set it up and is fluent in using it. (iperf)

Title: Re: x3 cpu usage
Post by cylent on Oct 2nd, 2008 at 2:56pm
well in order for iperf to work you'd have to have an iperf on the terminal but there isnt any.

i searched the modem bin directories and found no iperf.

whoever did it either had a iperf binary for the unit or had an image that came with iperf.


Title: Re: x3 cpu usage
Post by Scout on Oct 2nd, 2008 at 5:12pm
If you have a support contract with iDirect, they may be able to supply you with a version of iperf called iperf.infiniti

it is recommended that this is not used in standard set up as it increases the CPU load.  So they may ask you why you want it.  I believe it is really for the guys there to test and run on courses etc.

Title: Re: x3 cpu usage
Post by Scout on Oct 2nd, 2008 at 5:16pm
and it will run on the X3 also BTW

Title: Re: x3 cpu usage
Post by cylent on Oct 2nd, 2008 at 8:49pm
ya i know it'll run on x3.

the ONLY difference X3 has is the dvbs2 component. oh and the board is now smaller whereas in the 3100 the whole case filled the board. now the x3 has a smaller board but the casing is the same size as the 3100.

i am looking for an arm compiled iperf binary. i may end up compiling one myself.


Title: Re: x3 cpu usage
Post by ShareUrKnowledge on Oct 4th, 2008 at 9:22am
cylent,
The question you had about the CPU utilization during browsing and using the top command is normal, as I can see from your screen shot the CPU usage is low.
Secondly the extra 2 falcon processís are threads of the parent (first)falcon process, and not using 16M each, all 3 are consuming 16M, this can be verified by using the free command.

Good Luck.

Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-. All Rights Reserved.