Satellite Internet forum
https://www.satsig.net/cgi-bin/yabb/YaBB.pl
VSAT technology and installation >> iDirect Forum: hubs and terminals >> Error While Loading OPT File to X3 Modem
https://www.satsig.net/cgi-bin/yabb/YaBB.pl?num=1306916246

Message started by godstear on Jun 1st, 2011 at 9:17am

Title: Error While Loading OPT File to X3 Modem
Post by godstear on Jun 1st, 2011 at 9:17am
While I am loading the OPT file modem is giving the following error.

"ProcessOptionsDataMsg FAILED to parse OptionsDataMsg's text: Line 212: Malformed Assignment"

And I am sure i did install the bsd and x3 packages correctly also i have checked OPT file with the satellite providers and OPT file has no error. Therefore i have 4 modem which has the same error exactly.

I need your advices to solve this problem.

Title: Re: Error While Loading OPT File to X3 Modem
Post by Eric Johnston on Jun 1st, 2011 at 10:18am
You say "I have checked OPT file with the satellite providers ".   How did you do this ? A visual comparison of the displayed text may not be adequate to detect corruption.

I would get a newly generated uncorrupted file from the service provider and try that.

Maybe compare the new file with the possibly corrupted file byte by byte (use a hex editor so you can see what is there). Suspect a non printing character embedded in the visible text.

Alternatively retype the lines 211, 212 and 213.

If line 212 is the last line:  Examine the file for some strange byte(s) in last few bytes.  Is some significant amount of the file missing beyond line 212 ?  Is line 212 incomplete and only partly present ?

Best regards, Eric.

Title: Re: Error While Loading OPT File to X3 Modem
Post by godstear on Jun 1st, 2011 at 3:03pm
Thank you for answer

But i already try with new OPT file and i changed the file name even try to save it with diffrent name but all of them is not worked for me...

Title: Re: Error While Loading OPT File to X3 Modem
Post by Eric Johnston on Jun 1st, 2011 at 3:39pm
Ask the hub to explain that line and its format.

Ask if having that line is compatible with the software in your remotes.

It would be helpful if you could include the relevent section of the options file here. Others may then be able to offer their advice or comments.

Best regards, Eric.

Title: Re: Error While Loading OPT File to X3 Modem
Post by Malachy on Jun 10th, 2011 at 5:52pm
Dear Eric,

I also encountered the same problem today while loading the new option file to the modem.  I had another site which I downloaded the opt file and it went on well.

All this files were generated by the same NMS and they are all the same version.

What can be the issue?

Malachy

Title: Re: Error While Loading OPT File to X3 Modem
Post by Eric Johnston on Jun 10th, 2011 at 6:23pm
Maybe that particular modem (or is it 4 modems?) is unable to parse the opt file due to having different software.  Were the good and bad sites using the same hardware/software ?

Does the problem line contain some parameter that is particular to some software level and not to an earlier level ?

Print out the two opt files.  Are they really the same ?
Compare the two opt files with a hex file compare http://en.wikipedia.org/wiki/Comparison_of_hex_editorsto see if a non-printing character is embedded in the file.

You has 4 bad sites.  Do some of these now accept the file OK ?  Is so, could the opt file be corrupted or truncated due high bit error rate on the outlink downstream carrier to the remote ?.  The error message would report errors at different line positions in the file.  Can you see if the file size is the same after being received compared with its size before sending ?  Try sending it several times.  Try sending it by email to the local user and asking them to load it into the modem.

Best regards, Eric.

Title: Re: Error While Loading OPT File to X3 Modem
Post by andyflower on Jun 10th, 2011 at 7:47pm
have you tried loading the option file with console...just a suggestion!

Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-. All Rights Reserved.