Satsig logo
Satellite Broadband Forum.
Welcome, Guest. Please Login
Welcome to this satellite broadband discussion forum.  Wherever you are and whatever your problem we are here to help each other. Connecting to the internet via satellite is not always easy but is critically important to those in remote places or with poor terrestrial infrastructure.  Both service providers and customers are encouraged to contribute. Read the Forum rules.  Click Register at the bottom if you want to join.
  HomeHelpSearchLogin  
 
Pages: 1 2 
idirect os Problem (Read 6772 times)
sadaswd
Member
**
Offline



Posts: 6
Gender: male
idirect os Problem
Aug 8th, 2009 at 4:31pm
 
hi all 
ihave  Problem  with my idirect 3100  that  wen  Contact through HyperTerminal and run  any command  like 
fis load Linux
exec -c "root=/dev/mtdblock2 console=ttyS1,9600 single" or jast  exec  the HyperTerminal stak in this messg

Kernel panic: no init found. Try passing init= option to kernel
in redboot  i can  find  linux  and  rootfs
I think the Problem  in the rootfs  I think i need  Something like  ramdisk

Back to top
 
 
IP Logged
 
TDMAMike
Senior Member
***
Offline



Posts: 826
Gender: male
Re: idirect os Problem
Reply #1 - Aug 9th, 2009 at 3:25am
 
You may want to consider RMA'ing that unit.
Back to top
 

Regards, &&&&M
 
IP Logged
 
sadaswd
Member
**
Offline



Posts: 6
Gender: male
Re: idirect os Problem
Reply #2 - Aug 9th, 2009 at 2:55pm
 

Thank you for your Response
1- How do I do this ? I live in iraq  do u know any one can  help me ?
2 - i have  zImage for idirect 3100  do u konw  if i can reBuilding the os  by  the only  zImage
Back to top
 
 
IP Logged
 
TDMAMike
Senior Member
***
Offline



Posts: 826
Gender: male
Re: idirect os Problem
Reply #3 - Aug 10th, 2009 at 2:56am
 
RMA means send it to iDIrect for repair.  

So, you do have the zImage for your software version?

What software version are you using?
Back to top
 

Regards, &&&&M
 
IP Logged
 
sadaswd
Member
**
Offline



Posts: 6
Gender: male
Re: idirect os Problem
Reply #4 - Aug 10th, 2009 at 9:17am
 
i have  extract the cumulative pkg  7_1_1 in linux box  one of the file in pkg  is zImage
i have try upload  imge to  the modem
by  tftp  when  i do exec i hace  the  same  messg  the  HyperTerminal stak
Back to top
 
 
IP Logged
 
TDMAMike
Senior Member
***
Offline



Posts: 826
Gender: male
Re: idirect os Problem
Reply #5 - Aug 10th, 2009 at 11:48am
 
Provide me the exact command line strings you are using once you start TFTP on the client (assuming that you have copied the zImage file to the desktop of your client prior to start TFTP).

Thanks

Back to top
 

Regards, &&&&M
 
IP Logged
 
sadaswd
Member
**
Offline



Posts: 6
Gender: male
Re: idirect os Problem
Reply #6 - Aug 10th, 2009 at 4:44pm
 
ok  Sir  
i have install tftp server on my desktop in ip 192.168.0.2
the  idirect modem  is in ip 192.168.0.1 on red boot

>fis delet linux
>load -r -b 0x01600000 zImage  
After the  zImage  is loaded  
>fis create -f 0x50060000 -l 0x00100000 -e 0x001600000 -r 0x001600000 -s 0x00100000  linux
>fis load linux
>exec  or exec -c "exec -c "root=/dev/mtdblock2 console=ttyS1,9600 single" "

when i run exec  or exec -c   "exec -c "root=/dev/mtdblock2 console=ttyS1,9600 single""
ihave  the  same messge  try  to pass init  optin  to kernal
all  modem 's leds  are off  Except pwor and status solid Green  
Back to top
« Last Edit: Aug 11th, 2009 at 3:13am by TDMAMike »  
 
IP Logged
 
TDMAMike
Senior Member
***
Offline



Posts: 826
Gender: male
Re: idirect os Problem
Reply #7 - Aug 11th, 2009 at 2:59am
 
See my PM.
Back to top
 

Regards, &&&&M
 
IP Logged
 
sadaswd
Member
**
Offline



Posts: 6
Gender: male
Re: idirect os Problem
Reply #8 - Aug 11th, 2009 at 9:13am
 
hi
thank  Sir  ihave send  the Results in pm Please see it
Back to top
 
 
IP Logged
 
sadaswd
Member
**
Offline



Posts: 6
Gender: male
Re: idirect os Problem
Reply #9 - Aug 11th, 2009 at 3:44pm
 
thank you Sir
Back to top
 
 
IP Logged
 
dapsyra
Member
**
Offline



Posts: 6
Re: idirect os Problem
Reply #10 - Mar 20th, 2010 at 5:48pm
 
I have the same problem described in this post.  Can someone please share the solution with me?  Thank you
Back to top
 
 
IP Logged
 
cpcharry
Member
**
Offline



Posts: 1
Re: idirect os Problem
Reply #11 - Jul 31st, 2010 at 11:53pm
 
Hello:
We have the same kind of fail with iDirect X3 Evolution Modem, can someone send us list of commands to solve this problem.
We try with recovery procedure but present some address problems.
Thanks in advance.

My e_mail: cpcharry@hotmail.com
Back to top
« Last Edit: Aug 2nd, 2010 at 1:02am by cpcharry »  
 
IP Logged
 
ardalan_pesar
Member
**
Offline




Posts: 3
Re: idirect os Problem
Reply #12 - Aug 13th, 2011 at 8:18am
 
sadaswd wrote on Aug 10th, 2009 at 4:44pm:
ok  Sir  
i have install tftp server on my desktop in ip 192.168.0.2
the  idirect modem  is in ip 192.168.0.1 on red boot

>fis delet linux
>load -r -b 0x01600000 zImage  
After the  zImage  is loaded  
>fis create -f 0x50060000 -l 0x00100000 -e 0x001600000 -r 0x001600000 -s 0x00100000  linux
>fis load linux
>exec  or exec -c "exec -c "root=/dev/mtdblock2 console=ttyS1,9600 single" "

when i run exec  or exec -c   "exec -c "root=/dev/mtdblock2 console=ttyS1,9600 single""
ihave  the  same messge  try  to pass init  optin  to kernal
all  modem 's leds  are off  Except pwor and status solid Green  


I have the same problem. Please help me. I really need your jhelp. I run the zImage ny exec, initial installation process done but this error is occurred:
...
Further such events for this erase block will not be printed
JFFS2: Erase block at 0x00540000 is not formatted. It will be erased
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00560000: 0x4eac id
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00560004: 0x2555 id
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00560008: 0x952a id
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0056000c: 0x81fd id
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00560010: 0xdcb0 id
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00560014: 0xbe17 id
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00560018: 0xf76a id
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0056001c: 0xcb02 id
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00560020: 0x26e8 id
jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00560024: 0x1db9 id
Further such events for this erase block will not be printed
JFFS2: Erase block at 0x00560000 is not formatted. It will be erased
Cowardly refusing to erase blocks on filesystem with no valid JFFS2 nodes
Kernel panic: VFS: Unable to mount root fs on 1f:02
Back to top
 
 
IP Logged
 
dot
Senior Member
***
Offline



Posts: 119
Re: idirect os Problem
Reply #13 - Aug 13th, 2011 at 4:42pm
 
It appears as if you have more than just the Linux image corrupt, I had the same problem recently. You have successfully created a doorstop or you could have it repaired at great expense.
Back to top
 
 
IP Logged
 
ardalan_pesar
Member
**
Offline




Posts: 3
Re: idirect os Problem
Reply #14 - Aug 15th, 2011 at 9:31am
 
Would you plz give me some suggestions or comments about that and where do I find useful information about this deep problem?

How did you solve the problem?
Back to top
 
 
IP Logged
 
Pages: 1 2 
 
Anytime you want to order from Amazon...
If in Americas, please use the link below:

Useful links:
My latitude longitude (lat/long) finder
Email me: eric@satsig.net
Anytime you want to order from Amazon...
If in Europe, please use the link below: