Advertisment: Broadband via satellite
Advertisment: Planet Earth rotating animation

www.satsig.net

Satellite Internet Forum.

Welcome, Guest.        Forum rules.
      Home            Login            Register          
Pages: 1

sshd keeps stopping

(Read 3233 times)
Ex Member
Ex Member


Feb 28th, 2008 at 9:20pm  
I've got a 3100 that I tried to upgrade to 7.1.1 and it seems I've somehow corrupted the packages--I won't go into details so I can save a little face Smiley. I can still log in to the # prompt, so I want to use sshd and scp to get the 7.1.1 packages on the modem, but when I start sshd it only runs for 15-20 seconds before stopping. A look at /var/log/messages shows 'auth.info sshd[2968]: Received signal 15; terminating.'

Any ideas?
Back to top
 
 
IP Logged
 
TDMAMike
Senior Member
★★★
Offline



Posts: 826
Reply #1 - Feb 29th, 2008 at 2:47am  
Interesting...

When you are on the linux prompt (#) does the modem reboot (ever)?  

What is falcon telling you?  Check its status by typing:

service idirect_falcon status

Running or stopped?
Back to top
 

Regards, &&&&M
 
IP Logged
 
Ex Member
Ex Member


Reply #2 - Feb 29th, 2008 at 5:10am  
The modem does not reboot. I was able to load my correct options file via the hyperterm session, and copy/pasting it into falcon.opt. When I did that, it would reboot on its own. So I went back to the original that I had renamed, and it stopped doing that.

Falcon tells me it's running, and so is falcon_monitor.

The real trouble is that when I telnet 0, I see '[ErrorStack] admin@telnet:127.0.0.0;1024' and then the normal prompt. If I type in 'help' I see all of six commands listed. The command 'laninfo' is not one of them, and when I type that command I get 'unkown command'. That's just and example; same thing with other commands.
Back to top
 
 
IP Logged
 
sb
Member
★★
Offline



Posts: 31
Reply #3 - Feb 29th, 2008 at 9:36am  
hello,

i also had the same experience with a 3000 series modem

quite strange

does any one have an ideaof how to go about resolving the issue


Regards
sb
Back to top
 
 
IP Logged
 
TDMAMike
Senior Member
★★★
Offline



Posts: 826
Reply #4 - Feb 29th, 2008 at 11:43am  
So falcon is running..and sshd stops after falcon is running. Hmmm.  Interesting.

Do you have IP connectivity to this box (interfaces are functional?) I am sure you do if falcon is running.  However, it does sound as if something is corrupt in falcon process.  Especially if the telnet to localhost is not yielding the normal results (laninfo, etc).  

When you upgraded this 3100 to 7.1.1, you loaded the cumulative update on it first, correct? Followed by the image and opt?  Did you do all of this on console or by GUI?  

Have you tried stopping facon and running sshd?  Not sure if it will help but worth a try.  
Back to top
« Last Edit: Mar 1st, 2008 at 12:26am by TDMAMike »  

Regards, &&&&M
 
IP Logged
 
Ex Member
Ex Member


Reply #5 - Mar 3rd, 2008 at 12:37pm  
I figured this out, and then forgot to come back here and post the results. I had to stop the idirect_falcon service in order to keep sshd running. Mike, your guess was correct.

So once I had sshd running with no problems, I then SCP'd over the 7.1.1 cumulative and remote packages, as well as my option file. Then I continued via the console, and followed the directions in the iDirect Technical Note for Recovering iNFINITI Remotes. In Section 5 I repeated Step 6, doing it once for the Cumulative package, and then again for the Remote package.

Everything worked great after that. I can't say I'm happy this happened, but I'm glad I was able to learn a lot more about iDirect modems.
Back to top
 
 
IP Logged
 
Pages: 1